Hello and welcome to our community! Is this your first visit?
Register

Tire Rack

Results 1 to 9 of 9
  1. #1
    TEAM Member
    Join Date
    Jan 2009
    Location
    Brazil
    Posts
    165

    Default SCT X3 update problem

    Hello,
    Today I decided to update my SCT X3. Before start the process, I returned the car to stock. Then I used the "automatically check for updates" button on the SCT Device Updater. On the last part of the update process, I got an error message, I think it was the tune revision update part. Then the SCT X3 screen become missing some graphics.

    After this, I downloaded the .LWU firmware update file from SCT website and started the update by the "update firmware" button on the SCT Device Updater.

    My question is: it's taking too long to complete the update. Now it's "writing firmware". It took about 2 hours to reach 50% of the process. Is that correct?

    Thank you

  2. #2
    Moderator
    Join Date
    Nov 2007
    Location
    Florida/Shekou PRC
    Posts
    489

    Default Re: SCT X3 update problem

    First question, did you actually need to update the device?

    Second, where did you buy your device from again? Depending on this will determine if you can even use the updater program (overseas devices are different. Only US is supported with the automatic updating at the moment.)

  3. #3
    TEAM Member
    Join Date
    Jan 2009
    Location
    Brazil
    Posts
    165

    Default Re: SCT X3 update problem

    No need to update, I just decided to do it, since it was available and, according to SCT instructions on the website, there was no restrictions about upgrading.

    I bought it from EFI Components.

    The X3 is working fine now, it took about 5 hours to complete the writing firmware process. My question was about this long time.

    Thank you

  4. #4
    Moderator
    Join Date
    Nov 2007
    Location
    Florida/Shekou PRC
    Posts
    489

    Default Re: SCT X3 update problem

    Quote Originally Posted by Fernando_221 View Post
    No need to update, I just decided to do it, since it was available and, according to SCT instructions on the website, there was no restrictions about upgrading.

    I bought it from EFI Components.

    The X3 is working fine now, it took about 5 hours to complete the writing firmware process. My question was about this long time.

    Thank you
    No, it does not take that long to update. Most likely it did not update the unit.

    What is listed in device info currently?

  5. #5
    TEAM Member
    Join Date
    Jan 2009
    Location
    Brazil
    Posts
    165

    Default Re: SCT X3 update problem

    Quote Originally Posted by Blivit View Post
    No, it does not take that long to update. Most likely it did not update the unit.

    What is listed in device info currently?
    Its not working fine anymore lol.

    In device info is showing only the serial number. All other fields are incompletes or blank.

    Could you send me an older firmware file?? I'll be much grateful.

  6. #6
    Moderator
    Join Date
    Nov 2007
    Location
    Florida/Shekou PRC
    Posts
    489

    Default Re: SCT X3 update problem

    Quote Originally Posted by Fernando_221 View Post
    Its not working fine anymore lol.

    In device info is showing only the serial number. All other fields are incompletes or blank.

    Could you send me an older firmware file?? I'll be much grateful.
    What is the serial number?

  7. #7
    TEAM Member
    Join Date
    Jan 2009
    Location
    Brazil
    Posts
    165

    Default Re: SCT X3 update problem

    Quote Originally Posted by Blivit View Post
    What is the serial number?
    Here is:

    XP0322100ED53

    I tryed the firmware 1.2.123 .

    I think the original firmware was something with 14 in, don't remember at all.

    Thank you

    EDIT:
    The previous firmware was 1.2.122
    Last edited by Fernando_221; Oct 25, 2010 at 2:05 PM.

  8. #8
    Moderator
    Join Date
    Nov 2007
    Location
    Florida/Shekou PRC
    Posts
    489

    Default Re: SCT X3 update problem

    Quote Originally Posted by Fernando_221 View Post
    Here is:

    XP0322100ED53

    I tryed the firmware 1.2.123 .

    I think the original firmware was something with 14 in, don't remember at all.

    Thank you

    EDIT:
    The previous firmware was 1.2.122
    Your device was sold as a US device (based on the serial number.)

    You can use the firmware that is on our website, but you need the 3015 version. You will have to do it manually. To do so, hold down the cancel button as you plug the device in through usb. In the updater program then choose update firmware and select the 3015 lwu file.

  9. #9
    TEAM Member
    Join Date
    Jan 2009
    Location
    Brazil
    Posts
    165

    Default Re: SCT X3 update problem

    Quote Originally Posted by Blivit View Post
    Your device was sold as a US device (based on the serial number.)

    You can use the firmware that is on our website, but you need the 3015 version. You will have to do it manually. To do so, hold down the cancel button as you plug the device in through usb. In the updater program then choose update firmware and select the 3015 lwu file.
    At the first attempt I downloaded the 3015 version firmware.
    Now it's ok. In this "manually mode" it did a lot faster, less than 1 minute.

    Thank you


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •