Hello and welcome to our community! Is this your first visit?
Register

James Barone Racing

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Senior TEAM Member focusonfocus's Avatar
    Join Date
    Jul 2004
    Location
    toronto, on
    Posts
    4,438

    Default dirty maf sensor cause..??

    i cannot figure out what the hell is going on with my car..
    thought it was vaccum leak that causes car dies when stop in sudden..
    but turned out t be it is not vacuum leak..

    i haven't cleaned maf sensor at all..my car is 2000..and bought around 2002..
    would this cause engine dies??
    searched around and it can caue car run rich, and stall out or whatever..

    or old transmission can cause this as well??
    LOOKING FOR HAWKEYES STI(WORLD RALLY BLUE)

    2000 Ford Focus ZX3(OXFORD/CLOUD 6 WHITE) FSWERKS GT2871R Turbocharged @11psi
    2000 Ford Focus ZX3 KONA EDITION(DIRT BROWN METALLIC AKA SH*T COLOUR) Parted out

    BUILD THREAD-->http://forums.focaljet.com/team-rigz...hellll-no.html

  2. #2
    Super Moderators GapBoyPCS's Avatar
    Join Date
    Oct 2001
    Location
    Waterloo/Toronto, Ontario, Canada
    Posts
    11,222

    Default Re: dirty maf sensor cause..??

    Are you using a K&N or similar type of oiled filter? That's usually a main cause for dirty MAFs.

    Otherwise, have you done the usual bits of maintenance like plugs, plug wires, etc.?
    Richard
    2002 ZTS | Sangria Red |
    Over 521,000 km and 323,000 miles
    2012 SE Sport | Red Candy | Over 53,000 km and 33,000 miles

    [FJ] focaljet - Forum Guidelines - Welcome to the Jet - 2012 Focus - Team Canada - FJ Store - Sponsors - SEARCH

  3. #3
    Senior TEAM Member focusonfocus's Avatar
    Join Date
    Jul 2004
    Location
    toronto, on
    Posts
    4,438

    Default Re: dirty maf sensor cause..??

    yeah aftermarket filter that requires to spray oil..
    i will have to take maf sensor out and clean it..
    LOOKING FOR HAWKEYES STI(WORLD RALLY BLUE)

    2000 Ford Focus ZX3(OXFORD/CLOUD 6 WHITE) FSWERKS GT2871R Turbocharged @11psi
    2000 Ford Focus ZX3 KONA EDITION(DIRT BROWN METALLIC AKA SH*T COLOUR) Parted out

    BUILD THREAD-->http://forums.focaljet.com/team-rigz...hellll-no.html

  4. #4
    Senior TEAM Member ladybug04's Avatar
    Join Date
    May 2004
    Location
    Eugene, Or
    Posts
    2,733

    Default Re: dirty maf sensor cause..??

    qvc elctric contact clener on the maf, and good to go!
    Project pinky the crazy can corolla
    -04 focus(blown motor, waiting for donor and money)

    for sale: TC6 Factory team Buy it!!!

  5. #5
    Super Moderators GapBoyPCS's Avatar
    Join Date
    Oct 2001
    Location
    Waterloo/Toronto, Ontario, Canada
    Posts
    11,222

    Default Re: dirty maf sensor cause..??

    Quote Originally Posted by focusonfocus
    yeah aftermarket filter that requires to spray oil..
    i will have to take maf sensor out and clean it..
    Just make sure when you do clean and re-oil your filter that you don't overdo it.
    Richard
    2002 ZTS | Sangria Red |
    Over 521,000 km and 323,000 miles
    2012 SE Sport | Red Candy | Over 53,000 km and 33,000 miles

    [FJ] focaljet - Forum Guidelines - Welcome to the Jet - 2012 Focus - Team Canada - FJ Store - Sponsors - SEARCH

  6. #6
    TEAM Member
    Join Date
    Jan 2008
    Location
    Austin, Tx
    Posts
    825

    Default Re: dirty maf sensor cause..??

    might be an MAF sensor problem.. if not then check your alternator.

    hmm...

    other than those things the next thing i would look at is the transmission..

    2002 RED SVT Focus: #3279 of 4288
    "Race Track ready, girlfriend friendly."

  7. #7
    Senior TEAM Member focusonfocus's Avatar
    Join Date
    Jul 2004
    Location
    toronto, on
    Posts
    4,438

    Default Re: dirty maf sensor cause..??

    cleaned maf sensor..it wasn;t even dirty at all..
    and alternator..tested and voltage shows good..perfectly normal..

    i guess trransmission is the problem..trans fluid is leaking slow but not much..
    i am getting new transmission soon..so hope this help my situation..
    LOOKING FOR HAWKEYES STI(WORLD RALLY BLUE)

    2000 Ford Focus ZX3(OXFORD/CLOUD 6 WHITE) FSWERKS GT2871R Turbocharged @11psi
    2000 Ford Focus ZX3 KONA EDITION(DIRT BROWN METALLIC AKA SH*T COLOUR) Parted out

    BUILD THREAD-->http://forums.focaljet.com/team-rigz...hellll-no.html

  8. #8
    TEAM Member
    Join Date
    Jan 2008
    Location
    Austin, Tx
    Posts
    825

    Default Re: dirty maf sensor cause..??

    hmm.. do you have manual transmission? you might want to fill it up with trans fluid.. at least for the mean time. a slow leak let leaking for 10 months is more like a bad leak to me.

    2002 RED SVT Focus: #3279 of 4288
    "Race Track ready, girlfriend friendly."

  9. #9
    Senior TEAM Member ladybug04's Avatar
    Join Date
    May 2004
    Location
    Eugene, Or
    Posts
    2,733

    Default Re: dirty maf sensor cause..??

    check engine grounds too, i had all sorts of dying, not starting, other problems, and all it was was a bad engine ground, 125 bucks including diagnostic, and fixed!
    Project pinky the crazy can corolla
    -04 focus(blown motor, waiting for donor and money)

    for sale: TC6 Factory team Buy it!!!

  10. #10
    Senior TEAM Member focusonfocus's Avatar
    Join Date
    Jul 2004
    Location
    toronto, on
    Posts
    4,438

    Default Re: dirty maf sensor cause..??

    i don't think ground problem..it was like this before and have done battery relocation and added more wires like BIG 3 except power wire goes btw alternator to battery.

    mine is atx sadly..
    plus to what i described earlier about sudden stop thing, also when i stop on downhill and shift to reverse and car dies..unless i step on brake and gas pedal as well..

    i guess it is time for new transmission??
    LOOKING FOR HAWKEYES STI(WORLD RALLY BLUE)

    2000 Ford Focus ZX3(OXFORD/CLOUD 6 WHITE) FSWERKS GT2871R Turbocharged @11psi
    2000 Ford Focus ZX3 KONA EDITION(DIRT BROWN METALLIC AKA SH*T COLOUR) Parted out

    BUILD THREAD-->http://forums.focaljet.com/team-rigz...hellll-no.html

  11. #11
    Super Moderators GapBoyPCS's Avatar
    Join Date
    Oct 2001
    Location
    Waterloo/Toronto, Ontario, Canada
    Posts
    11,222

    Default Re: dirty maf sensor cause..??

    Have you ever had your computer scanned for any diagnostic codes? This includes having a shop scan for any trouble codes associated with the tranny?
    Richard
    2002 ZTS | Sangria Red |
    Over 521,000 km and 323,000 miles
    2012 SE Sport | Red Candy | Over 53,000 km and 33,000 miles

    [FJ] focaljet - Forum Guidelines - Welcome to the Jet - 2012 Focus - Team Canada - FJ Store - Sponsors - SEARCH

  12. #12
    Senior TEAM Member focusonfocus's Avatar
    Join Date
    Jul 2004
    Location
    toronto, on
    Posts
    4,438

    Default Re: dirty maf sensor cause..??

    there is no code...
    LOOKING FOR HAWKEYES STI(WORLD RALLY BLUE)

    2000 Ford Focus ZX3(OXFORD/CLOUD 6 WHITE) FSWERKS GT2871R Turbocharged @11psi
    2000 Ford Focus ZX3 KONA EDITION(DIRT BROWN METALLIC AKA SH*T COLOUR) Parted out

    BUILD THREAD-->http://forums.focaljet.com/team-rigz...hellll-no.html

  13. #13
    Senior TEAM Member v8FociDreams's Avatar
    Join Date
    Jan 2007
    Location
    Carlsbad, CA
    Posts
    1,668

    Default Re: dirty maf sensor cause..??

    Hold on. Lets back up a minute.
    First off, a bad trans will never cause any car to die at idle. EVER. You will have completely different symptoms such as the car revving to redline but not moving.
    Second, have you checked the wiring harness that plugs into the MAF sensor? Mine acted the same when I had a cold air intake on mine because the location of the MAF caused the wires to chafe causing one of the wires to break. Check them carefully.
    Quote Originally Posted by LamarWH
    Is Dateline NBC even trying anymore? Must have been the new one.... "To Catch A Jackass"

  14. #14
    Senior TEAM Member ladybug04's Avatar
    Join Date
    May 2004
    Location
    Eugene, Or
    Posts
    2,733

    Default Re: dirty maf sensor cause..??

    id personally take it to a ford shop, reputable, and have them do a diagnostic on it, 75-80 bucks usually, and can save you lots of money in the long run!!!

    bryan
    Project pinky the crazy can corolla
    -04 focus(blown motor, waiting for donor and money)

    for sale: TC6 Factory team Buy it!!!

  15. #15
    TEAM Member
    Join Date
    Jan 2008
    Location
    Austin, Tx
    Posts
    825

    Default Re: dirty maf sensor cause..??

    Quote Originally Posted by v8FociDreams
    Hold on. Lets back up a minute.
    First off, a bad trans will never cause any car to die at idle. EVER. You will have completely different symptoms such as the car revving to redline but not moving.
    Second, have you checked the wiring harness that plugs into the MAF sensor? Mine acted the same when I had a cold air intake on mine because the location of the MAF caused the wires to chafe causing one of the wires to break. Check them carefully.
    A bad trans can cause the engine to stall when stop suddenly.... low transmission fluid can also cause this, it does not necessarily trigger the CEL to come off.

    i agree that an erroneous MAF reading can sometimes cause the engine to die at idle, most of the time you can't even drive your car coz it will stumble, stall and die but if it really is the wiring harness, why is the CEL not on? if it is an exception, error or something then the diagnostic is somewhat easy and quick, you don't really have to go to the stealer to give away your money. Simply unplug the MAF from the system, CEL will come off.. thats natural, your engine should not have any problem idling at all. i hope it helps.

    2002 RED SVT Focus: #3279 of 4288
    "Race Track ready, girlfriend friendly."


 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •