Hello and welcome to our community! Is this your first visit?
Register

FJ Gear Store

Results 1 to 6 of 6
  1. #1
    Rookie
    Join Date
    Jan 2008
    Posts
    5

    Default 03 Focus SE sputtering/rough engine, no dealership around

    Aloha,

    Hoping to get some feedback. I live in Alaska and there's no dealer here, in fact I'd have to ship the car on a boat to get to the nearest one.

    Stats on car:

    2003 Focus SE 4 door 2.0 L motor

    • 104,000 miles
    • new engine mounts
    • new brakes
    • power steering pinion leak
    • exhaust leak was fixed 2 years ago, ran rough ever since
    • use synthetic/high mileage oil
    • mix cheap gas (safeway, fred meyer-kroger) but used mid/high grade Shell/Chevron for last 3,000 miles
    • new battery
    • hasn't been in shop for "check-up"
    • new spark plugs 3 years ago

    Car still shakes a bit and runs rough, even at idle. Also when at speed, it seems to sputter/lose power.

    any thoughts? I'm looking at getting a new DPFE sensor and fuel filter, and stop using the cheap a@#$* fuel and going with Tesoro mid-high grade.

    thanks in advance!

  2. #2
    Junior Member drostedrummer89's Avatar
    Join Date
    Dec 2010
    Location
    Royal Oak, MI
    Posts
    97

    Default Re: 03 Focus SE sputtering/rough engine, no dealership around

    Welcome! a few things you may want to take a peek at:

    1) inspect spark plugs, wires, inspect coil for cracks in housing.
    2) any check engine light?
    3) what did you have fixed with the exhaust? Is your catalytic converter stock? How about your o2 sensors?
    4) Timing belt is due at 100k miles, time to get that done
    5) check your motor mounts, lower mount may need new bushings

    Matt
    For sale: New OEM Zetec parts. 01 intake manifold, cams, cam gears, valvesprings, harmonic balancer, injector harness. PM me for details.

    00' Red ZX3: Volant, ported throttle body, ported intake manifold, 4-1 Ebay header (soon to be replaced by titanium wrapped SVT) no cat, 2.5" exhaust, Magnaflow resonator and muffler, Ford Racing underdrive pulley, Lowered 2" with Koni Adjustables.

  3. #3
    TEAM Member
    Join Date
    Nov 2007
    Posts
    290

    Default Re: 03 Focus SE sputtering/rough engine, no dealership around

    If you have codes, the DPFE will usually kick up P0401 - EGR flow insufficient. If you have that code, check connections first, and if everything looks kosher, replace the sensor.

    If your codes refer to the O2 sensors, look at them externally and at their connections. If all looks good, remove the upper one first (nearest the engine) and check if it is caked with carbon. This is a chicken-and-the-egg situation... either the bad sensor caused the carbon buildup, or the carbon buildup caused the sensor to read improperly. Most people would replace it if it is in question like I am saying, so it is up to you whether you want to take a gamble a clean it, or spend the money for a replacement.

    If there is no code, I would definitely look at the coil and wires. You did mention you replaced the plugs 3 years ago, that is more of a mileage-based item, not time. How many miles on the plugs?

    Give us all the info you have, and I am certain one of us can help you figure it out. Let me know.

  4. #4
    Rookie
    Join Date
    Feb 2011
    Posts
    48

    Default Re: 03 Focus SE sputtering/rough engine, no dealership around

    I had a situation recently that the car missed on number 1 cylinder.the spark plug was cracked when it was installed and it took a few 100 miles before the carbon or whatever inside the plug burned thru the crack,and allowed the spark to travel down the side of the plug to ground.Cadilac Northstar engine in this case but any plug can be cracked if dropped or the socket gets crooked on it.Just something to check for.Remove each plug and try not to touch the porcilain sides till you can see them good.A crack will be full of black carbon.

  5. #5
    Rookie
    Join Date
    Jan 2008
    Posts
    5

    Default Re: 03 Focus SE sputtering/rough engine, no dealership around

    Hey thanks for the feedback.. well its gotten worse.

    Today while driving home from work the engine started hesitating around 40 mph and just felt like I had no power at all... didn't even sound like the car was shifting. then the engine check light started flashing. Car seemed to drive better with o/d off. at idle car ran OK... but exhaust sounded like a moped. also smelled something burning.

    My friend's diag computer is broken, so I'm flying blind until I locate another one.

    Looked at the DPFE and its intact, will be checking all the hoses tomorrow, could be a leak somewhere.


  6. #6
    Rookie
    Join Date
    Jan 2008
    Posts
    5

    Default Re: 03 Focus SE sputtering/rough engine, no dealership around

    so put in new spark plugs, new EGR, and new solenoid & it still sounds & drives like a moped... drove it about 5 miles and no CEL or flashing CEL, thank god, but really really need to get a diagnostic computer.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •