Hello and welcome to our community! Is this your first visit?
Register

Perfect Circle Autosport

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Car keeps running when ignition is turned off

    Hi I'm new to this site and I have a "strange " problem. Sometimes when the car is turned off (key removed) the car keeps on going, although the rev counter is at zero and everything else is off, even the alarm indicator comes on but the car is still idleing. If you push the accelerator nothing happens. After about 2 - 3 minutes the car stops. I had the car at a dealer and he says has never seen this before and doesn't know what is wrong.
    The car has been at the garage about 10 times for a idleing problem namely when you stop at an intersection the idle drops and sometimes stalls and sometimes it settles at normal revs. This doesn't happen all the time and never when the car is cold. Also when the ECU is reset it is fine for a few weeks and then it starts acting up.When the idle is bad I also have a problem sometimes with pre-ignition when I switch the car off.
    The dealer replaced the throttle body about 2 weeks ago but the idle problem is still there and now the running on issue has started.
    Since the running on is very intermittent, the guys at the dealer wouldn't have believed me if they had not seen it for themselves, they say it will be hard to resolve. I assume that there must be someone who has seen this before, because I don't understand why there are no error codes etc when the ECU must know the car is switched off since it activates the alarm but also the injectors, coils, air flow etc must be activated to keep the car running.
    Please can anyone shed some light on this.

    Thanks

    Roy SA
    Last edited by GapBoyPCS; Jun 25, 2010 at 10:13 PM. Reason: Removed extra spaces.

  2. #2
    Super Moderators GapBoyPCS's Avatar
    Join Date
    Oct 2001
    Location
    Waterloo/Toronto, Ontario, Canada
    Posts
    11,222

    Default Re: Car keeps running when ignition is turned off

    It'd help to know a bit more about your car, such as the year, engine, mileage, and if you have modified the car in any way. Also, is your car alarm aftermarket? Do you have any other accessories installed on the car?

    Your dealer may have access to a device similar to a "black box". Usually with intermittent issues like this some dealers will use it, hook it up to your car, and see if they can get any readings from it.
    Richard
    2002 ZTS | Sangria Red |
    Over 521,000 km and 323,000 miles
    2012 SE Sport | Red Candy | Over 53,000 km and 33,000 miles

    [FJ] focaljet - Forum Guidelines - Welcome to the Jet - 2012 Focus - Team Canada - FJ Store - Sponsors - SEARCH

  3. #3
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Re: Car keeps running when ignition is turned off

    Hi it is a 2006 2.0 litre 92,000Km, the alarm is standard and other that the sound (which was done over a year ago) it is standard.
    About 3 months ago the car had a problem with the Inlet runner manifold which was replaced, but the actual problem was one of the solenoids that activate the manifold flaps. the problem I am having is that the agents seem to only be able to fault find based on the error code. With the IRM they told me it was the ctual manifold that had to be replaced when in fact it was only a solenoid, however since i have an extended aftermarket warranty they replace both, so I have a perfectly good manifold as a spare. However this current problem started not long after they replaced the manifold and I'm beginning to think that maybe they inadvertently did something when they were changing the manifold, apparently the idle control valve is below the manifold.
    Today the car had problems with idling and when I got home it wouldn't switch off. I called another dealer and he said he would be at the Ford factory on Monday and he would speak to them about it but for the engine to keep going there must be power to the ECU, so it may be a faulty relay or something. I am think that maybe I should get Ford to reset the ECU and see if the problem persists, this may also show if the idle problem is linked to the running on, since normally when they reset the ECU the idling problem goes away for a time.

  4. #4
    Rookie
    Join Date
    Jun 2010
    Location
    Johannesburg SA
    Posts
    7

    Default Re: Car keeps running when ignition is turned off

    Hi, I have the exact same problem with my Ford Focus 1.6 SI 2005. It runs for about 5 - 10 seconds after the key is turned off. My Ford dealer also cant tell me whats wrong. It also only happens sometimes and normally runs fine just after the engine light has been turned off. Its also a standard car with only sound which was installed 3-4 years ago. Please let me know if you found the problem, my car is in to ford today again.

  5. #5
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Re: Car keeps running when ignition is turned off

    Hi Stark My car is also in ford today so I will see what they come up with. I was talking to another dealer at the w/e and he said that it souldn't be possible since when the car is turned off the voltage to the ecu is removed, therefore he thinks that maybe a relay is sticking. I hopefully will see this guy on Thursday and if I find out anything I will let you know

  6. #6
    Rookie
    Join Date
    Jun 2010
    Location
    Johannesburg SA
    Posts
    7

    Default Re: Car keeps running when ignition is turned off

    Hi Roy, I got my car back. They said I had a loose fuse (dont know how that happens) and underneath the car there is some Main Module plug which was faulty.
    The engine light is off now and the car switches off normally and smoothly as it should, for now..!! (hold thumbs). This was giving me a headache, especially if not evan a dealer can tell you whats wrong, and they tell you they have never seen this before. Ill keep you up to date too ...

  7. #7
    Rookie
    Join Date
    Jun 2010
    Location
    Johannesburg SA
    Posts
    7

    Default Re: Car keeps running when ignition is turned off

    Nope!!! headache back again.. engin light came back on and car idles again with key turned off and removed... !!! Phoning Ford again this morning.... Please someone help!!!!

  8. #8
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Re: Car keeps running when ignition is turned off

    Hi Stark Maybe it's early days but they seem to have fixed my running on problem, apparently it was a loose earth strap on the inside fuse box. So far it seems OK but I'm driving up to Jhb this afternoon so that will be a better test. The idle problem also seems a bit better but this sometimes takes time to manifest itself. Good luck today with Ford

  9. #9
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Re: Car keeps running when ignition is turned off

    Hi It appears that the bad earth on the internal fuse box was the problem. Drove 600km and it doesn't run on. It may have been my fault as I changed the pollen filter which requires that the fuse box be dropped and its bracket removed, maybe I moved a wire when I was doing it. The idle problem is still there but appears to be worse when you start the car, not so bad when you stop at a stop street etc. Still need an answer on that one

  10. #10
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Re: Car keeps running when ignition is turned off

    Hi Stark Any Joy? My car seems to be fine except for erratic idle when starting if the car is warm. I spoke to another ford tech who was at the factory and hea asked about my running on problem and the consensus was a bad earth somewhere as the used negitave switching - seem to have fixed most of my problems. However it leaves me with a potentially good spare throttle body. Let me know what happens

  11. #11
    Rookie
    Join Date
    Jun 2010
    Location
    Johannesburg SA
    Posts
    7

    Default Re: Car keeps running when ignition is turned off

    Hi Roy, im taking it to an auto electrician. The guy says he had a car with a similar problem not too long ago. Guarantees me that he will solve my problem. 3 Ford dealers say they can't help me (after paying R1000), makes me wonder if id buy a Ford again, but lets see what this guy says. Have to book the car in for at least 2 days leading to some tranportation headaches but I want my car 100% again so it needs to be done. Will keep you posted...

  12. #12
    Rookie
    Join Date
    Jun 2010
    Location
    Durban South Africa
    Posts
    11

    Default Re: Car keeps running when ignition is turned off

    Just a quick update - Car started with its problems but after 40km on a dirt road it seemed fine. However it was in for a service last week and at the weekend the problems started again, both running on and not idling, both of which are intermittent. Car is back at ford today to get the hydraulic engine mount changed (I canged the gearbox rear mount at the service) and to re-look at the problems. It's starting to look more like an earth fault, but maybe they are looking at the wrong earth, apparently there are quite a few.
    Well lets see what happens.

  13. #13
    Rookie
    Join Date
    Jun 2010
    Location
    Johannesburg SA
    Posts
    7

    Default Re: Car keeps running when ignition is turned off

    At last my problem is solved..!!!

    Took my car to probably the best auto electrician in south africa. Whitin 3 hours my car was 100% with no problems at all. The ABS earth was loose and a faulty relay was found.

    Take your car to a good auto electrician.Ford dealers suck at finding the problem on their own cars, they just worry about the engine light and when that is reset ' your car is fine sir! '
    until it comes back on and then ' we dont know whats wrong !'
    After I payed you R340 - thank you hey!!

    Anyway, my car is fixed up and drives like a dream, we learn out of our mistakes i suppose..

  14. #14
    TEAM Member
    Join Date
    Jul 2010
    Location
    maryland
    Posts
    262

    Default Re: Car keeps running when ignition is turned off

    I have a problem with my car where i turn the key off and it keeps running. Do you know what relay he replaced?

  15. #15
    Rookie
    Join Date
    Jun 2010
    Location
    Johannesburg SA
    Posts
    7

    Default Re: Car keeps running when ignition is turned off

    Yes, its the same relay that turns your car's sleep mode on (thats if you have a ford focus). It has different stages I was told. If the relay gets totally worn your battery will also be drained within a day or two if you dont start it.

    If you stand in front of the car with the fuse/relay box on the right, in the engine compartment. Its the right, bottom relay (in the corner) costs about R40.

    Its worth a try as pre ignition on a ford focus is not common - or lets say i couldn't find guys with the same problem on the net.

    If you need more info , let me know...


 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •