Hello and welcome to our community! Is this your first visit?
Register

James Barone Racing

Results 1 to 3 of 3
  1. #1
    Newbie
    Join Date
    Dec 2011
    Posts
    1

    Default P1506 error code = IAC

    Morning, I am new to the forum. I have an issue with my 2000 2.0 DOHC Zetec. 2 weeks ago , in the morning, I went outside to start my car. When it started it barely wanted to idle, it idled so low that the car shook and I had to keep my foot in it... Once it warmed up, the throttle no longer needed my assistance. The car actually idled way too high however, it wouldnt idle high until I gave it throttle, than I would take my foot off the gas and it would temporarily stay at the rpm i revved it up to. If I let it set running for a little whlile, say 20 seconds the idle would come back down and stay at an above average idle at 1,100 rpm. I looked behind the TB to check for any loose hoses and there were no loose vacuum lines. The next day, I started it up and once it warmed up the check engine light came on. I hooked it up to a diagnostic reader and it gave me the code, P1506. Did some research and the code refers to the IAC.

    I took out the IAC cleaned it and put it back in and it still ran high. I ordered 2 parts from napa and they gave me an 01 IAC, than they gave me an IAC that had an elbow connector that made it impossible to fit. SO, I went to rock auto and ordered one. Its here and the gaskets drying to it right now... IF this doesnt solve my annoying high idle issue, what do I do next? What else do I check for...

    Well, here I go to roll around in the snow under my focus. Ive done this about 3 times before and it only takes about 10 min.. Be back soon.

  2. #2
    Senior TEAM Member COSVT03's Avatar
    Join Date
    Oct 2004
    Location
    Minneapolis, MN
    Posts
    4,411

    Default Re: P1506 error code = IAC

    It will, also check for Vac leaks.
    Once an IAC goes bad, there is no cleaning it, it must be replaced.
    #3052 of 3985
    Full N/A SVT Build

  3. #3
    Senior TEAM Member bflesher's Avatar
    Join Date
    Aug 2010
    Location
    Minnesota
    Posts
    2,348

    Default Re: P1506 error code = IAC

    Possibly the pcv hose could be leaking also if IAC doesn't work after replacement and no leaks are found.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •