Hello and welcome to our community! Is this your first visit?
Register

FJ Gear Store

Results 1 to 2 of 2
  1. #1
    Newbie
    Join Date
    May 2013
    Posts
    1

    Default Temp gauge DROPS from normal to cold when running rough at high speed!!!! Help!!!!

    I have a 5 speed 2002 Ford Focus ZTS Mach edition and I have owned it since brand new. I have numerous issues that I'm hoping is linked to just a faulty sensor. Please help!!!

    The car runs rough when driven hard or when going uphill. It gets worse and would seem to lose power when you step on the gas pedal more but seems to go back to normal if I slightly release my foot off the pedal for a second. The temperature gauge would drop from normal to cold if it continues to run rough in the freeway for a while! Check engine light blinks when problem occurs.

    It also overheats when stopped too long or when driven at low speed. It doesn't overheat when the ac is running coz it intermittently turns the radiator fan on. Problem is, the rpm drops every time the fan turns on making the car shake for a few seconds. Note that the vehicle idles normal and the rpm only drops when I hear the fan turn on.

    This has been ongoing for months. It was ok to drive in the winter coz i didn't have to turn the ac on to keep the car from overheating. It also won't run rough if I drive like Im just cruising on a $100k Bentley.

    Can someone please help me diagnose the problem. I plan on fixing this on my own. I'm not a mechanic by trade but I'm pretty handy and have quite a bit of experience working on different cars. Thanks!
    Last edited by Jitsjunkie; May 3, 2013 at 1:51 AM.

  2. #2
    Junior Member
    Join Date
    Sep 2012
    Posts
    50

    Default Re: Runs rough at high speed, temp gauge goes from normal to cold!!!!

    It sounds like your thermo is stuck open, when that happens the coolant doesn't cool enough in the rad core and it just keeps recirculating especially if it stays normal during idle at all times up until heat builds evenly in your cooling system making temp go up. My only thoughts good luck


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •