Ford Focus Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I'm just finishing up rebuilding my 2013 focus that was in a front end collision. It has a automatic transmission and I am having some problems with it.

I keep getting odb codes:
P087A
P087B
P087E
and sometimes P287A I think was the code.

The transmission will move the car forward but when shifted in to reverse it will not move, just revs up. The wiring harness was damaged in an area but I'm pretty sure I repaired it all.

Anybody have an idea on what I should try next?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
I solved that issue. Turns out the clutch actuator motor was damaged inside. Now I have another issue. My airbag light is on. I had the module reset and replaced the two front crash sensors. What else could it be? I'm going to double check the wiring on them two plugs as well now.
 

·
I
Joined
·
13,288 Posts
I solved that issue. Turns out the clutch actuator motor was damaged inside. Now I have another issue. My airbag light is on. I had the module reset and replaced the two front crash sensors. What else could it be? I'm going to double check the wiring on them two plugs as well now.
Have any way to pull the airbag system codes?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I'm not sure how to do that. It doesn't display them through obd-II so I'm assuming a dealer has to hook directly up to it. Do you know of any way to do it?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
I am really struggling with this one. I verified the wiring to the two front crash sensors and the wiring to the steering wheel bag back to the airbag control module. The driver wheel and knee bag have been replaced and the front crash sensors. Pretensioners did not deploy. Anyone have any idea on what else to try before I'm forced to bring this to the dealer?
 

·
Registered
Joined
·
89 Posts
After airbags deploy the control module has to be replaced. You can count the airbag light flashes and then lookup the flash codes online. Code 13 is crash data memory full and requires a new control module
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7 (Edited)
The control module has been professionally reset to original state. I do not get any light flashes when I turn on the car. The light comes on for a few seconds, turns off for about 2 seconds and then comes back on steady.

Do they still output error codes? Maybe my unit isn't getting power?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
I forgot to update this post. I got the car working!

The airbag problems was the passenger seat restraint module had to be synced to the main restraint module with I think for software. So that cleared my airbag problems.

I also had a problem with the cruise control not working and turns out that was the front passenger speed sensor on the wheel. It had debris in it due to the repairs that were done. Once I fixed that problem and replaced the clutch actuator all my error codes went away and the car has not had a problem since!

Thanks everyone for your help.
 

·
Registered
Joined
·
4 Posts
I also have a 2013 Ford Focus that I am rebuilding I was wondering what the problem is with my Ford Focus. It had a front end crash and once I got it running because the battery was low the transmission seem to be acting really funny. Once I drove it 10 minutes later the transmission drove and shifted perfectly and smooth. Engage in reverse and drive perfectly that now when I woke up this morning and I turned it on it will go to drive but it will not going to reverse. I am wondering if I am having the same problems it seems like the wire harness was also damaged I will double check but there seems to be nothing wrong with it. I was also having a little bit of problems with the car starting you have to click the key a couple of times before the actual car will turn over. I also changed the starter and there seem to be water inside the transmission I think it might have had some water damage.
 

·
Registered
Joined
·
4 Posts
okay I think I found the shift motors that are on the sides of the transmission. I found this video on YouTube that was real helpful on all the other problems that were related to ford focus transmission. My question is now which shift motor is the one that controls the reverse. Here is a video link and maybe you can tell me wich one it is. 2011+ Ford Fiesta & 2012+ Focus Shudder- Clutch Replacement: http://youtu.be/YVJnNPbjjjs
 

·
Registered
Joined
·
4 Posts
2011+ Ford Fiesta & 2012+ Focus Shudder- Clutch Replacement: http://youtu.be/YVJnNPbjjjs



I found this video on YouTube and it was very helpful locating a clutch motor that you were talking about. My question is not on which one of the motors is the one that activates the reverse in the transmission. Also I wanted to know if it was something that you just pull out and reinstall or does it have to be programmed by the dealer so that the computer learns it again. This car has me so stressed out I swear I will never buy another Ford Focus in my life at an auction again. If anyone could please help me I'm begging you guys I am so stressed over this.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
My problem was the clutch motor on the front. Sorry I forget which one. Look for damage. Also my wiring harness was causing all sorts of problems with the ABS system because the wire was basically shattered inside the casing.
 
1 - 13 of 13 Posts
Top